Failed to Download Required Content

The Cooking Dash app doesn't load it just displays the error above- it's not my internet. All my other apps work perfectly fine.  Can I just re-install my game? I'd like to talk to someone about this error. It's been awhile now.. My ingame username and forum name is the same.

Comments

  • maimaikulit22maimaikulit22 Registered Users, Member 2 Posts
    Experiencing the same problem 😔
  • ozzywifeozzywife Registered Users, Member 2 Posts
    Same problem here. Cleared enough space on phone. Been back and forth with the customer support people which are trying to help as much as possible but still no fix unless, they say if we get a Facebook account  it may be possible to recover account..?
  • ozzywifeozzywife Registered Users, Member 2 Posts
    Really like the game.. hope someone can find a fix for us...spent a few bucks here and there on it
  • doantuankhoidoantuankhoi Junior Member Registered Users 146 Posts
    @ozzywife
    Have you tried playing on another device, like an emulator?
Sign In or Register to comment.