Over the course of the last five years, Racing Rivals has grown into one of the most hardcore racing games in the world. This loyal community has spent countless hours competing in millions of races in “winner take all” fashion – all in the name of Turf Wars and pink slips.

However, all good things must come to an end… After spending time evaluating Rivals and its future – we’ve decided that it’s time to move on. Simply put, the revenue generated from Racing Rivals unfortunately no longer covers the cost of operations. This was not an easy decision to make.

On March 31st, 2019 – Rivals will be racing off into the sunset, and will be permanently shut down. Current players have until this date to utilize any accumulated virtual currency. We’ll be offering some massive reductions in the cost of crates, installs and repairs in addition to a reduction on timers as you race your way into the history books. Effective immediately, no new in-app purchases will be permitted.

In closing, a resounding and sincere THANK YOU to our extremely driven fans for your loyalty and dedication over the years – we hope you’ve enjoyed playing Racing Rivals as much as we’ve enjoyed creating it.

Tie glitch is back, please fix

bankshot84bankshot84 Junior Member11 PostsRegistered Users
I confirmed that the tire glitch is back. I'm not sure what os is on but I'm using Android. I raced a user and at the end after I won it said "race was a tie". After a few days I went back to that same user and raced again, we went pink and at the end after I won it said "race was a tie". Please fix this. Also ice noticed that other people can some how hold the lights so it delays and throws your timing off. Please fix that too. Thank you

Comments

  • [RR] PhoenixX[RR] PhoenixX Administrator 1,575 PostsModerators
    Be aware that getting a tied race result twice doesn't necessarily mean that the tie glitch is back. Please contact support with as much detail as possible about this issue by pressing the "?" in game.
  • wuddlebunnywuddlebunny Junior Member 84 PostsRegistered Users
    i found the bug that generating random tie race error and wrong race results. i had tried to race myself with my another account. let's say my main account have D class red car and my second account have D class blue car. i start the challenge and i DON'T press launch on both my cars. on my main screen, i see my blue car act like computer car and ran away and my second screen, i see my red car act like computer car and ran away.
  • [RR] PhoenixX[RR] PhoenixX Administrator 1,575 PostsModerators
    Please contact support about this issue with as much detail as possible (and screenshots or video, perhaps) by pressing the "?" in game.
  • lowriderboolowriderboo Junior Member 3 PostsRegistered Users
    It happens to me all the time. They say to look for ? Mark but i cant find one

Sign In or Register to comment.