Over the course of the last five years, Racing Rivals has grown into one of the most hardcore racing games in the world. This loyal community has spent countless hours competing in millions of races in “winner take all” fashion – all in the name of Turf Wars and pink slips.

However, all good things must come to an end… After spending time evaluating Rivals and its future – we’ve decided that it’s time to move on. Simply put, the revenue generated from Racing Rivals unfortunately no longer covers the cost of operations. This was not an easy decision to make.

On March 31st, 2019 – Rivals will be racing off into the sunset, and will be permanently shut down. Current players have until this date to utilize any accumulated virtual currency. We’ll be offering some massive reductions in the cost of crates, installs and repairs in addition to a reduction on timers as you race your way into the history books. Effective immediately, no new in-app purchases will be permitted.

In closing, a resounding and sincere THANK YOU to our extremely driven fans for your loyalty and dedication over the years – we hope you’ve enjoyed playing Racing Rivals as much as we’ve enjoyed creating it.

Ryyst Blog #6 Supplemental - Update on the Issues

2Next

Comments

  • errick2109errick2109 Registered Users 38 Posts
    BMW black safety car can't seem to get it tuned load in and says it's 51 downgrade something says it's 49 exit out back in its back 51...down grade something else 49...exit load back in 51 again ....ign errick2109 annoying during turf
  • errick2109errick2109 Registered Users 38 Posts
    also the menu says the down grade done too with all this spent quite a few gems trying to get this not sure what's up
  • dulwhitedulwhite Registered Users 118 Posts
    This happens with many cars to me, as well. Real problem. Can't tune.
  • NotPhunnyNotPhunny Registered Users 54 Posts
    Stuck tunes have been a problem since before the update. Sometimes if I send a stuck car to a friend them take it back it will unstick the tune.most times it doesn't help though
  • CUSTOMPIRATE23535CUSTOMPIRATE23535 Registered Users 13 Posts
    @rrryst my ign is custom pirate 2353 my main question about the graphics will we be able to go back and forth if we wish to because id like to be able to do that
  • CUSTOMPIRATE23535CUSTOMPIRATE23535 Registered Users 13 Posts
    The new graphics are ok but my problem since i updated to 6.0 i have been having nothing but overheating problems with my Polaroid tablet and all kinds of lag and errors coming up constantly getting disconnected from the tournament lobby befor it starts i would really like the 5.3 graphics back my polaroid cant handle the new ones and is a issue with my device over heating when i havent been on the game that long barely a half hr and my device is hot theres something wrong but i can say its not my device i just got it last month befor my birthday
  • the elementsthe elements Registered Users 24 Posts
    My issue still hasn't bee resolve by cie have submitted two tickets and still nothing this is really frustrating
  • chamberlainskchamberlainsk Registered Users 8 Posts

    Hey all,

    We all deeply appreciate your patience while we work through the issues affecting players. We have looked at all the info and feedback you all have provided and we are going to be burning the midnight oil as it were to get these issues resolved.

    We are currently testing a new update which should resolve many of these issues.

    Matte and Flake Paint issues
    Wheel issues
    Latency
    Over all graphics
    Global Chat (option to turn off notifications)

    We will also continue to look into the feedback provided. We've seen your concerns about the following:

    Sounds
    User Interface (Color scheme, fonts)
    Race Results screens
    Racing Buttons
    Text sizes
    Thumbnails and more


    6.0.2 doesn't even let me play!!!! all it says is reload every time I open the game!!!
  • dulwhitedulwhite Registered Users 118 Posts
    Thanks for the patch. Already dramatic improvement noticed.
  • C Dees NutsC Dees Nuts Registered Users 1,271 Posts
    With this round of fixes there are new problems. The experimental graphics now appear to have taken a step back rather than forward. On my HTC 10, the cars look more cartoonish then they were before the latest update, especially those with matte paints. However, I was never a fan of the 6.0 graphics to begin with, so I switch to the 5.3 graphics to go back to what I thought would be more to my liking only to find out that there are issues with those graphics as well. Everything is dark, except for the glare that comes off cars at certain angles. While it's understandable that the game is getting more realistic, does that justify adding in elements that are negative experiences? The mattes look fine in 5.3, all things considered, but now colored rims are distorted. My cars that are supposed to be Midnight Blue are currently dark gray.

    The home screen interface is still a gross misuse of space compared to what it was in 5.3, which I support by saying that the fact that I have to scroll down on the left side of the screen to claim my performance crate while 2/3s of the right side of the screen are empty, which is just plain silly. The game still reeks of trying to get too fancy when you already had such a good thing going. This patch makes it easier for me to continue my hiatus from Racing Rivals and inch closer and closer to not playing ever again.
  • dulwhitedulwhite Registered Users 118 Posts
    I still feel that the numbers while tuning for horsepower, torque, weight are too small to read, framerate still should be 60+ but it is locked at 30. But still, this is a huge step forward from the previous..."update".
  • AnonymousAnonymous Registered Users 3,837 Posts
    Still can't add team members even though the team leader has changed that option, nothing ever shows up in my inbox although it says I have messages, im co leader and don't see any options like the leader of the team
    Image and video hosting by TinyPic
  • dwdtuningdwdtuning Registered Users 12,932 Posts
    @[rr] downshift

    I still get crazy amount of lag at launch. Impossible to launch. Before 6.0 this was my main kill device. Had 0 lag.

    https://imgur.com/1xWssd7. My phone

    Ign.

    T h y honey p o t

    Thanks
    ★ HATERS MAKE US FAMOUS ★

    ★#1 MM ★

    ☆ Stalkers are creepy ☆

    >:)
  • Tennesseeboy84Tennesseeboy84 Registered Users 13 Posts
    @rrryst I wanted to say thank you for all the hard work you and your team have doing to keep this game great. I know it's not easy. Just wanted to say thank you and keep it up :)
  • NASTYTHUGNASTYTHUG Registered Users 1,121 Posts
    @[RR] DownShift/@ [RR] Ryyst, I have the nexus 7, pixel lx and the note 7. This is horrible nothing but lag and now that I can actually get in to my garage it takes like 2 mins for me to get in the shipyard and when I try to get in a lobby it takes just as long. I don't care about the cheap as gift that everyone got...I just want no lag. Once again I will be missing turf cause the lag is bad. IGN: N A S T Y (2 spaces)
  • dulwhitedulwhite Registered Users 118 Posts
    Still want the frame rate to be unlocked to 60fps
  • errick2109errick2109 Registered Users 38 Posts
    still having the tuning issues but huge improvement so far
  • [RR] Ryyst[RR] Ryyst Registered Users, Moderators 3,814 Posts
    We're working on the lag. We now have an idea of whats causing it, just need to get a fix for it.
    IGN: The Real {RR} Ryyst
    Soon to be Ex-Carbonated Community Manager

  • NevesomoNevesomo Registered Users 10 Posts
    edited November 2016

    We're working on the lag. We now have an idea of whats causing it, just need to get a fix for it.

    Are you talking about low fps (performance), tuning issues or about rims ?
  • killinemsoftlykillinemsoftly Registered Users 4,432 Posts
    An eta on that lag hotfix ryyst ?


  • the elementsthe elements Registered Users 24 Posts
    Man I haven't even had my loading problem fixed yet
  • KILRLSX04KILRLSX04 Registered Users 3 Posts
    @RR.Dropshift @RYYST The cars and crates are appeciated. But on my android devices I'm still experiencing slowness in garage moving around and upgrading cars also when switching to a different car and garage dissapers. Lag on clicking to race opponents. Lag on the drop and shifts it's just like the tach needle is in slow motion sometimes. My ios is ok so far but I experimented with graphics on and off and all of that makes it worse if any extra things are selected in options menu. 2 weeks ago my kids and I hit 61st place no self crushing or straight up got after it. It was a huge struggle with the android devices as if it was what it use to be it wouldn't of been so hard. My phone use to do perfect everything before 6.0.1 and 6.0.2 now it's equivalent to a dial up speed game performance wise and it's frustrating when Trying do what you need to do to play and have fun.
    Devices still affected and almost no change seen even after the 6.0.2 update are.

    Rca android based tablet
    Samsung Galaxy Note 4
    Samsung Galaxy tab 3/4
    Samsung Galaxy S3
    Samsung Galaxy express 3
  • getterdonegetterdone Registered Users 158 Posts
    Im haveing all the same problems with my s4 i even tried an android emulater for my desktop same thing lol i really just want to race miss the game and my good friends everyone on my team has quit or moved on plz just go back to the 5.3 and add little upgrades dosnt matter if its a 100 of em lol atleast we would be able to play. Thanks for your time,have a great day
  • CircusOfSinsCircusOfSins Registered Users 11,304 Posts
    Here's a new one for ya...why do I not have this...

    Some people do...I do not...what's up with that ?


  • getterdonegetterdone Registered Users 158 Posts
    I havent seen it either lol
  • dahater75dahater75 Registered Users 74 Posts
    When will the nos failure atv.003 rt or better be fixed. I'm guessing never at this point. It sucks to be so damn fast with reaction that it cost me cars. In turf my good rt is my worst enemy
  • Evo8MREvo8MR Registered Users 32 Posts
    Hi sir need help
    Game lagy , sometime normal but mostly Lagy
    Device; iPhone 7
    Ios ; 10.1.1
    Memory ; 128gb
    Conection; 4g and wifi with 20 Mbps

    Please update it sir
    Thanks
  • DeynnispDeynnisp Registered Users 123 Posts
    @Ryyst; Thanks for always keeping the RR community as informed as possible. What is GLU doing to patch up whatever it is some racers are exploiting which makes them run faster times than the legit racers, when will that issue be patched up? It seems that whenever a "new" update gets released new issues associated with release pops up giving RR community new lever of frustration and disgust. Not to mention that much longer the wait for the game to be as hack/glitch free. My perspective on this latest "speed glitch/hack" whatever you want to call it is how can someone find a folder which to exploit and use to their benefit so soon after a major release if not being pointed the way by insider with prior knowledge of the ins and outs of that particular update. That said, i hope this latest glitch, loop hole gets patched up ASAP because i'm seeing more people just not playing or investing their hard earned money on this game. I know for one i'm not and wont be until they patch up this latest issue.

    Bossmann out.
  • SlxyarhSlxyarh Registered Users 5,109 Posts
    thanks for the free performance crates glu your mistake hahah

    ill be serious i found 4 free performance crates had no idea there was a issue

    you'r mistake your loss glu not my problem

    please don't get mad at me i spent them had no idea smh they were there
  • johnjohansenjohnjohansen Registered Users 2 Posts
    I was wanting to know if there will ever be chance of trading blue prints
Sign In or Register to comment.