Over the course of the last five years, Racing Rivals has grown into one of the most hardcore racing games in the world. This loyal community has spent countless hours competing in millions of races in “winner take all” fashion – all in the name of Turf Wars and pink slips.

However, all good things must come to an end… After spending time evaluating Rivals and its future – we’ve decided that it’s time to move on. Simply put, the revenue generated from Racing Rivals unfortunately no longer covers the cost of operations. This was not an easy decision to make.

On March 31st, 2019 – Rivals will be racing off into the sunset, and will be permanently shut down. Current players have until this date to utilize any accumulated virtual currency. We’ll be offering some massive reductions in the cost of crates, installs and repairs in addition to a reduction on timers as you race your way into the history books. Effective immediately, no new in-app purchases will be permitted.

In closing, a resounding and sincere THANK YOU to our extremely driven fans for your loyalty and dedication over the years – we hope you’ve enjoyed playing Racing Rivals as much as we’ve enjoyed creating it.

Are you experiencing latency or a drop in frame rate?

2Next

Comments

  • tnfordguytnfordguy 11 PostsRegistered Users
    IGN: TN Ford Guy
    Phone: Motorola Droid Maxx
    Op system: Android 4.4.4

    It may just be the age of my phone, but I experience a lot of lag in chat, tuning menus, showroom, and in race lobbies at random. Also shows me offline at random. Has not caused me to lose any cars because I try not to pinks when I am lagging. Only way my lag stops is if I restart the game, and then it's a countdown to when it starts again. Some days immediately, other days not at all. Hope this helps.
  • thunderbomb3thunderbomb3 5 PostsRegistered Users
    No frame rate issues just latency. During racing and even rotating cars around in the garage.
  • sufizamasufizama 1 PostsRegistered Users
    IGN : sufizama

    Device : Samsung galaxy A7 2016

    Device operating system version : 6.0.1

    Hello guys i really hate the lags i cant even play like this....pls fix this or u can make on the setting that u can change the performance so everybody can make it not lag...i hope u guys changes thx bro
  • Lordbeerus199412Lordbeerus199412 3 PostsRegistered Users
    I can't login to my account

    Ign: TOP NOTCH KILLER
    device: LG Optimus f3

    I switched device now I can't access my account
  • djames80djames80 7 PostsRegistered Users
    null
    Yes but my other device and ign work perfectly fine. The odd part is the phone i use to race with is about 5 years old and runs on android 4.4. The lg stylo 2 has every issue thats out there when running rivals. Real slow frame rate, latency, lag you name it that device experiences it. The lg isnt but about 6 months old.
  • djames80djames80 7 PostsRegistered Users
    edited February 2017
    One more thing. This may not be the place but im pretty sure you will see it and im sure you have some influence on development. The launch button...will we get a fix? Also the size of the launch button, its too small since 6.0. My main complaint about control layout in races though is the size and position of the NOS button. For it to be closer to the upshift paddle and a bit larger or to be able to repositon the NOS button would be a beatiful thing. This isnt just coming from me. I can tell you that i know of many, many other ppl with this same concern. Thanks for your time and effort Rryst. We appreciate it emencely!
  • TH3_INS4NE_M00NTH3_INS4NE_M00N 10 PostsRegistered Users
    In-Game Name: TH3 INS4NE M00N
    Device: iPad Mini (First Generation.)
    Device Version: iOS 10.2.1 (14D27)
    What I am Experiencing: I am experiencing some lag whenever I play in the multiplayer lobby and tournaments. Yet the game runs pretty good in turf wars and or racer showdown. I'd like it to run perfectly in Multiplayer, Tournaments, Turf Wars AND Racer Showdown, if possible, please and thank-you.
  • YungApexYungApex 8 PostsRegistered Users
    Device: Ipad Air 2
    Version: 6.0.1

    I get a drop in frame rate and get lag in some cars, while others are completely fine. And the launch button issue i believe has not been fixed yet so that makes it even worse for a n0bb racer like me. Hopefully you guys at carbonated can turn all these issues around and make the game better for everyone.

    ALSO
    When I have perfectly good internet, I'm in my garage doing garage-y stuff, I get a message saying "We have made improvements to your account, please restart" And I restart my game and nothing happens. Why is this?

    Thanks,
    Daniel-san
    i am the one, don't weigh a tonne don't need no gun to get respect up on the streets.
  • SlxyarhSlxyarh 5,109 PostsRegistered Users
    had a massive frame job in turf while pinking lucky he spun cause my rt was at 0.135 please fix
  • ciechuciechu 6 PostsRegistered Users
    Hello. Where is this sale for silver box?
  • aubassplayeraubassplayer Junior Member 2,725 PostsRegistered Users
    Gonna be at the beginning of turf. They released the announcement early by mistake
    Ign: au(space)bass(space) player
    Team: 9am michi
  • [RR] Ryyst[RR] Ryyst Administrator 3,814 PostsRegistered Users, Moderators

    I can't login to my account



    Ign: TOP NOTCH KILLER

    device: LG Optimus f3



    I switched device now I can't access my account

    You'll need to contact CS. Please refer to this thread:
    http://forums.racingrivals.com/rivals/discussion/206503/looking-for-assistance-account-issues
    IGN: The Real {RR} Ryyst
    Soon to be Ex-Carbonated Community Manager

  • RAINBHOWDASHRAINBHOWDASH Junior Member 71 PostsRegistered Users
    For me it's not just down to device but I'll leave that information too

    1 device is
    Nexus 6
    Android version 7.0
    Frame drops inconsistent frame rate (shoots from a 40 to a 25 randomly) I noticed external programs overlaying have lag on top of them more then from 5.0 (my recording app Mobizen lags on the taps so does messenger)

    2nd device

    Samsung j7 model SM-J700T
    Same as Nexus 6 just going between 45 and 30 on the frame rate during recording dips down into the 20s sometimes (I have video of the giant difference in frame rate between when I had this phone (old update) and now after the recent patches)
  • [RR] Ryyst[RR] Ryyst Administrator 3,814 PostsRegistered Users, Moderators
    YungApex said:

    Device: Ipad Air 2
    Version: 6.0.1

    I get a drop in frame rate and get lag in some cars, while others are completely fine. And the launch button issue i believe has not been fixed yet so that makes it even worse for a n0bb racer like me. Hopefully you guys at carbonated can turn all these issues around and make the game better for everyone.

    ALSO
    When I have perfectly good internet, I'm in my garage doing garage-y stuff, I get a message saying "We have made improvements to your account, please restart" And I restart my game and nothing happens. Why is this?

    Thanks,
    Daniel-san

    Like which cars are fine and which ones are bad? What paints are on them?
    IGN: The Real {RR} Ryyst
    Soon to be Ex-Carbonated Community Manager

  • crasi_maxcrasi_max Junior Member 2 PostsRegistered Users
    In-Game Name:
    madbull86

    Device:
    Samsung galaxy note 3

    Device Operating System Version:
    Android 5.0

    What are you experiencing:
    Whenever in multiplayer, turf r showdown lobby, when I'm about to launch my cars, I would experience a few sec of frame drop jus b4 the light turn green. Which would mess up reaction time r cuz me foul.

    The light in my car headlight doesn't show, but the beam shows on the road, a few of my car had matte paint, which was remove with the 6.0 update.

    Some time when I'm racing and my opponent hold the light, the race didn't, we both get 0.000 rt, but I loose the race. Please look into that situation as well.
  • Roush SportRoush Sport 1,484 PostsRegistered Users, Moderators
    crasi_max said:

    In-Game Name:

    madbull86



    Device:

    Samsung galaxy note 3



    Device Operating System Version:

    Android 5.0



    What are you experiencing:

    Whenever in multiplayer, turf r showdown lobby, when I'm about to launch my cars, I would experience a few sec of frame drop jus b4 the light turn green. Which would mess up reaction time r cuz me foul.



    The light in my car headlight doesn't show, but the beam shows on the road, a few of my car had matte paint, which was remove with the 6.0 update.



    Some time when I'm racing and my opponent hold the light, the race didn't, we both get 0.000 rt, but I loose the race. Please look into that situation as well.

    If you turn the enhanced graphics off, the headlights will look "right" again, and the matte paint will look "better" than it does with the graphics turned on.
  • king_gabeking_gabe 2 PostsRegistered Users
    Launch button not working properly please fix
  • FranPvFranPv 1 PostsRegistered Users
    edited February 2017
    In-Game Name: FranPv17 N2
    Device: Samsumg Galaxy S4
    Device Operating System Version: lolllipop 5.0.1
    What are you experiencing: I have 14-17fps all time fix please play this game a long time ago, thanks.
  • nakazumynakazumy 7 PostsRegistered Users
    In-Game Name: PLAZMER

    Device: Sony Xperia Z3 Compact

    Device Operating System Version (Usually found in settings/about: Android 5.1.1

    What are you experiencing:
    Alot of lag after a few mins not hours in-game i have to restart the game alot of times like in less than 30min like 7 times.. Smooth? Not even close looks like it runs the whole game in low frames per second the only thing that doesnt lag its when i race with others.
  • getterdonegetterdone 158 PostsRegistered Users
    I am having problems with all of that first i was told my phone was to old ok can understand that so i went and spent money really didnt have on a 6.1.1 tablet just for this game and to my amazement the same damn thing. Sorry but i have been playing for almost three years and am so frustrated right now about to call it quits. Ive road the storm of updates over and over and over again. So here is my ing. Name and the other information u have asked for please please fix the game really dont want to quit.my ing. Name is MIDNIGHT RAMBLER am playing on a rca voyager and the version is android 6.0.1 3.14.o+ model # rct6873w42 build# rct6873w42-android6.0-v20-v1.18.30-m06. I also have the highest speed internet available in my area at 32mb per sec. I have been experiancing very slow responce times lag impossible to even play at times. Thanku for your time and truely hope it can be fixed or im done. Have a great day.
  • TWINK3PTOTWINK3PTO 5,848 PostsRegistered Users
    In-Game Name: TWINK3PTO
    Device: Samsung Galaxy Note 3
    Device Operating System Version (Usually found in settings/about): Android 5.0
    What are you experiencing: After about (10) minutes of gameplay, I'm starting to experience choppiness and a very sickening lag, where the delay press time translates to approximately .100 in action time on the game. This lack of action time takes toll in my performance on the track and, ultimately, costs me cars. I find that the lag is the worst in Sydney due to the abundance of additional background graphics (distant structures, the running stream below the bridge, etc.). Most of my team tend to skip the Sydney events specifically for that reason.
  • SLAPNUTS316SLAPNUTS316 31 PostsRegistered Users

    @Ryyst

    In-Game Name: WHAT 316
    Device: Nexus 7 2013
    Device Operating System Version: 6.0.1
    What are you experiencing: Choppy while racing, very laggy/delay while racing, happens all the time, pretty much unplayable at this time. Have reinstalled game, didn't help.

    Thank you if your able to fix!
  • CamsDraft10662CamsDraft10662 1 PostsRegistered Users
    In game name: Cams Draft 10662
    Device: Samsung Galaxy Tab E
    Operating system: Android 6.0.1
Sign In or Register to comment.