Over the course of the last five years, Racing Rivals has grown into one of the most hardcore racing games in the world. This loyal community has spent countless hours competing in millions of races in “winner take all” fashion – all in the name of Turf Wars and pink slips.

However, all good things must come to an end… After spending time evaluating Rivals and its future – we’ve decided that it’s time to move on. Simply put, the revenue generated from Racing Rivals unfortunately no longer covers the cost of operations. This was not an easy decision to make.

On March 31st, 2019 – Rivals will be racing off into the sunset, and will be permanently shut down. Current players have until this date to utilize any accumulated virtual currency. We’ll be offering some massive reductions in the cost of crates, installs and repairs in addition to a reduction on timers as you race your way into the history books. Effective immediately, no new in-app purchases will be permitted.

In closing, a resounding and sincere THANK YOU to our extremely driven fans for your loyalty and dedication over the years – we hope you’ve enjoyed playing Racing Rivals as much as we’ve enjoyed creating it.

Turf and local races so laggy

mCr08mCr08 Senior MemberRegistered Users 128 Posts
Hello dear admin, i notice that the new update is laggy. All my launch are always delay because if the lag im talking about. I noticed that everytime i enter turf war the lag suddenly appear. Then when i get out if the turf still laggy. BUT when u start the app and NOT go to tufr its not laggy. I saw one of your reply about this topic, im making a new one coz i noticed something in it. Its not on the device of internet connection why its laggy. Its on the update of game itself. I tried eve going to the strongest connection of my net yet it still laggy. I guess some graphics error may cause this one as i also noticed the developers change some graphics in it. I have pictures to prove that graphics affected the lag we are expriencing. But i got to admit i love the friend list now because its fast, but ill rather prefer it slow as long as the game itself is not laggy. Im hoping you guys can solve this immediately, i lost lots cause of this lag issue. Im not blamming anyone herevp i just want that the game would be samecas before :) thank you and more power to Racing Rivals. Truly yours Angel ;)

Comments

  • [RR] Sage[RR] Sage Administrator Moderators 556 Posts
    We have seen a couple reports of "laggy" gameplay but personally I haven't seen it at all. The network guys continue to monitor the server performance so if we find anything they will adjust as needed.
  • mCr08mCr08 Senior Member Registered Users 128 Posts
    Thank you sage for your time :) well im hoping it will be fixed soon. Many players experience it so i guess its not my device. :)
  • GONZOGONZO Player Moderator Registered Users 2,993 Posts
    It's not just your device. It's the game. Now after every race I get the searching for a stronger connection bs. But hey at least we have turf wars lmao
  • roestreyevroestreyev Senior Member Registered Users 1,443 Posts
    I think this game is getting too heavy for my iPhone 4S...Laggy for me too, even against bots...
  • SonicRacing1SonicRacing1 Junior Member Registered Users 15 Posts
    game feels really glitchy/laggy smh... Plz fix RR
  • BootyshockaBootyshocka Member Registered Users 75 Posts
    Sage I think the Issue may be Frame lag, I noticed with the last update things look bigger. I don't know if y'all did a resolution change or what. You can tell te lag if u tap the throttle at launch, it works fine till about the time the lights start then it's like it doesn't want to let u back up into the green. Perhaps it's just my device but you wouldn't think an IPad4 would have issues. Just my 2 cents
  • Goldtop1955Goldtop1955 Senior Member Registered Users 556 Posts
    Sage I think the Issue may be Frame lag, I noticed with the last update things look bigger. I don't know if y'all did a resolution change or what. You can tell te lag if u tap the throttle at launch, it works fine till about the time the lights start then it's like it doesn't want to let u back up into the green. Perhaps it's just my device but you wouldn't think an IPad4 would have issues. Just my 2 cents
    Exactly the problems I am having plus I get graphics freezing, out of sync with the sound. And worst it after I win a race it automatically boots me to the highest room possible. They claim there is no issue..... Sounds like a lack of interest in the problem.
  • [RR] Sage[RR] Sage Administrator Moderators 556 Posts
    We test on a variety of devices and I wouldn't think an ipad4 would have an issue. I have forward over the threads to ensure the testing team has all the information you guys have provided. So far I haven't heard of any reproduced errors regarding this but they are still looking.
  • Drift skid 20Drift skid 20 Member Registered Users 34 Posts
    Play the game longer then 5 minutes and u will see the bugs
  • Drift skid 20Drift skid 20 Member Registered Users 34 Posts
    Games ruined now bro
  • AnoezAnoez Junior Member Registered Users 27 Posts
    [QUOTE=[RR] Sage;n13257]We test on a variety of devices and I wouldn't think an ipad4 would have an issue. I have forward over the threads to ensure the testing team has all the information you guys have provided. So far I haven't heard of any reproduced errors regarding this but they are still looking.[/QUOTE]

    it was not about connection, but laggy gameplay dude
    have ever tested with ipad 3 or iphone 4s?
Sign In or Register to comment.