Over the course of the last five years, Racing Rivals has grown into one of the most hardcore racing games in the world. This loyal community has spent countless hours competing in millions of races in “winner take all” fashion – all in the name of Turf Wars and pink slips.

However, all good things must come to an end… After spending time evaluating Rivals and its future – we’ve decided that it’s time to move on. Simply put, the revenue generated from Racing Rivals unfortunately no longer covers the cost of operations. This was not an easy decision to make.

On March 31st, 2019 – Rivals will be racing off into the sunset, and will be permanently shut down. Current players have until this date to utilize any accumulated virtual currency. We’ll be offering some massive reductions in the cost of crates, installs and repairs in addition to a reduction on timers as you race your way into the history books. Effective immediately, no new in-app purchases will be permitted.

In closing, a resounding and sincere THANK YOU to our extremely driven fans for your loyalty and dedication over the years – we hope you’ve enjoyed playing Racing Rivals as much as we’ve enjoyed creating it.

UCL / BUG on PC

Green240sxGreen240sx Junior MemberRegistered Users 29 Posts
Hello,

I used to play this game all the time around half a year ago on iOS / iPhone,

I just started to play again today on facebook "Computer" and I just got to the first race of the B Class campaign with my yellow Lancer and when I click race the game screen go's pure black " Full screen and not full screen ", and im forced to do the CTL + ALT + DELETE to exit facebook because to whole website freezes, and NO, its NOT my PC, my computer is like 2 weeks old, and NO viruses or anything like that... Quad core, 12GB of RAM, I mean its not my computer that's the issue. Please fix this issue Racing Rivals admins,

ALSO

Racing Rivals...

PLEASE PLEASE PLEASE make a UCL... Used Car Lot, were we can sell our cars to other people without getting scammed trying to sell your car during a race...

it would help out a TON,

like the good ol' Nitto Legends days...

that would be Awesome

Thanks and God Bless

Comments

  • [RR] Ryyst[RR] Ryyst Administrator Registered Users, Moderators 3,814 Posts
    I just checked and the campaign races work fine. What browser are you using? What version of the the browser are you using? Are you on a PC or laptop? What kind of graphic card are you using? Are your drivers up to date? (Yes even a new computer may have out of date drivers) Have you cleared your browser's cache?
    IGN: The Real {RR} Ryyst
    Soon to be Ex-Carbonated Community Manager

  • Green240sxGreen240sx Junior Member Registered Users 29 Posts
    Thanks for responding,

    I have a Dell Inspiron 3847 Desktop,
    Intel Core i5-4440 Quad Core 3.1GHz, 3.3GHz Turbo Boost
    12GB of RAM, 8GB and 4GB, Samsung and Hyundai
    Intel HD 4600 Integrated Graphics

    Im on Facebook using Internet Explorer 11 (Up to date).

    Yes I cleared cache
    ----

    Also when I get in a car (Any car), and I go to multiplayer race track it loads a little bit and stops (freezes)... And I have to exit Facebook and get in again, This happens around 50% of the time... Maybe my Internet connection? im getting,

    10 Ping
    around 1mbps
    and like 0.75 uploadtime

    Thanks for the help...

    and,

    The UCL, are you guys planning on putting it in the game? or no.
  • Green240sxGreen240sx Junior Member Registered Users 29 Posts
    I just tried again and the campaign race worked...
Sign In or Register to comment.