Over the course of the last five years, Racing Rivals has grown into one of the most hardcore racing games in the world. This loyal community has spent countless hours competing in millions of races in “winner take all” fashion – all in the name of Turf Wars and pink slips.

However, all good things must come to an end… After spending time evaluating Rivals and its future – we’ve decided that it’s time to move on. Simply put, the revenue generated from Racing Rivals unfortunately no longer covers the cost of operations. This was not an easy decision to make.

On March 31st, 2019 – Rivals will be racing off into the sunset, and will be permanently shut down. Current players have until this date to utilize any accumulated virtual currency. We’ll be offering some massive reductions in the cost of crates, installs and repairs in addition to a reduction on timers as you race your way into the history books. Effective immediately, no new in-app purchases will be permitted.

In closing, a resounding and sincere THANK YOU to our extremely driven fans for your loyalty and dedication over the years – we hope you’ve enjoyed playing Racing Rivals as much as we’ve enjoyed creating it.

Racing Rivals FaceBook BUG

Green240sxGreen240sx Junior MemberRegistered Users 29 Posts
Hello,

I am currently playing on a Computer with the latest RR update. When I get into the game, everything is good, but when I go to turf, the whole (Game Screen) screen goes black and I cant do anything. It does not load or anything. I restarted the computer. I got out of FB and got back in like 5 times already. And its the same thing every time. I had this same exact issue last turf. And I couldn't turf because of that. Then 1 day it just went away. This issue started for me again when I tried to get on today after waking up. RR Admins, Please check this issue out. My team is rank 121 and they really need my help. And Yes my internet Explorer is up to date.

Thanks and God Bless

Comments

  • Green240sxGreen240sx Junior Member Registered Users 29 Posts
    The turf started working about around 12 hours after I posted this tread... I un-installed the utility web player, Re-installed it. I tried EVERYTHING I can think of... Nothing could've solved it. That's when I gave up trying, then I got back on like 4 hours later and I guess it started working on its own... Now its the Racer Showdown and its doing the exact thing again... I have no idea whats up... but I hope it gets fixed. RR Admins, PLEASE look into this, I'm positive i'm not the only one with this issue.
  • Green240sxGreen240sx Junior Member Registered Users 29 Posts
    I missed the whole Racer Showdown due to this bug.... I am very disappointed that I did not even get a reply or anything from the RR Admins...
    Please Fix this RR Admins...
  • SmittzSmittz Junior Member Registered Users 66 Posts
    Hello,
    About that black out problem, it a Ms, game and the video card driver problem it's most likely in the source video driver some times gets out of sequence it's like the gears skip at thoot and the game video driver mis steps like it can't keep in tune with RR FACEBOOK MS the comp video drivers.. try update the MS VIDEO DRIVER and your nvid driver u can believe it or not
  • Green240sxGreen240sx Junior Member Registered Users 29 Posts
    Okay, The PC is a Dell Inspiron that's only about 2 months old, It's got Intel HD 4600 Integrated Graphics My Internet Explorer is up to date I do all the Windows Updates... I has not done it since the 24th of March and I just tried to get on today and same exact thing, It's not letting me turf at all, Or join a race track...
Sign In or Register to comment.