Over the course of the last five years, Racing Rivals has grown into one of the most hardcore racing games in the world. This loyal community has spent countless hours competing in millions of races in “winner take all” fashion – all in the name of Turf Wars and pink slips.

However, all good things must come to an end… After spending time evaluating Rivals and its future – we’ve decided that it’s time to move on. Simply put, the revenue generated from Racing Rivals unfortunately no longer covers the cost of operations. This was not an easy decision to make.

On March 31st, 2019 – Rivals will be racing off into the sunset, and will be permanently shut down. Current players have until this date to utilize any accumulated virtual currency. We’ll be offering some massive reductions in the cost of crates, installs and repairs in addition to a reduction on timers as you race your way into the history books. Effective immediately, no new in-app purchases will be permitted.

In closing, a resounding and sincere THANK YOU to our extremely driven fans for your loyalty and dedication over the years – we hope you’ve enjoyed playing Racing Rivals as much as we’ve enjoyed creating it.

Forums are going crazy

Galactic EmperorGalactic Emperor Registered Users 3,940 Posts
Lot of problems going on.

1. Instead of the usual Bold, Italic, Underline etc. buttons, it's just a bunch of bold buttons, that don't even work.
2. When I click on the notification symbol (earth) it takes me to my profile page, instead of the dropdown window.
3. When I click on the inbox symbol, it takes me straight to the inbox page, instead of the dropdown window.
4. When I post things, I can't see them until I reload the page.
5. When I try to click Like, LOL, Disagree etc. it tells me to enable JavaScript. Which I definitely have enabled.

Tried reloading, and turning JavaScript off and on, still doesn't work. Help please.
I can see the Statue of Liberty from here

Comments

  • Galactic EmperorGalactic Emperor Registered Users 3,940 Posts
    6. The post editing button doesn't work.
    7. When I try to clear that wall post, just above the wall, it says something has gone wrong.
    8. When I try to delete a wall post, it says I don't have permission to do that.
    I can see the Statue of Liberty from here
  • Galactic EmperorGalactic Emperor Registered Users 3,940 Posts
    9. When someone posts on a discussion I've posted on/bookmarked, I'll see there are new posters, but I don't see the new posts when I open the discussion.
    I can see the Statue of Liberty from here
  • Old WomanOld Woman Player Moderator Registered Users 2,799 Posts
    Yeah, I'm having a few of these problems.
  • Galactic EmperorGalactic Emperor Registered Users 3,940 Posts
    Ah, it's working again.
    I can see the Statue of Liberty from here
Sign In or Register to comment.