Doesn't recognise my email address

LondonBoyLondonBoy Registered Users, Member 23 Posts
Anyone had issues logging in? It refuses to accept my email address

Comments

  • DFBBDFBB Registered Users, Moderators, Member, Moderator 4,910 Posts
    Try doing the tutorial, then signing in.
    Mi casa es su casa...except during cvc. 
  • Superapids135Superapids135 Experienced Member Registered Users 368 Posts
    I have the same problem. Ugh whatever. The formats woerd too and too many restrictions. I think 20 isn’t for me
  • LondonBoyLondonBoy Registered Users, Member 23 Posts
    Yep, did the tutorial. Still won't let me sign in
  • LudwigMonsterLudwigMonster Registered Users, Member 381 Posts
    Same. Says my email address is invalid (which it's not). I've used the same email for the past two seasons.
    I also chose the "forgot my password" option in the 19 version and nothing got sent to me.
    Sent a ticket in to CS but I suppose I won't hear back from them for days. What a sh*t show.
  • MulderkenMulderken Registered Users, Member 152 Posts
    Same. Says my email address is invalid (which it's not). I've used the same email for the past two seasons.
    I also chose the "forgot my password" option in the 19 version and nothing got sent to me.
    Sent a ticket in to CS but I suppose I won't hear back from them for days. What a sh*t show.
    Check your spam box. 
  • JCAM80JCAM80 Registered Users, Member 468 Posts
    My problem with "invalid email" was I autopasted it and it put a space behind. Easy fix. Hope that's your issue too
  • fatDaddyfatDaddy Registered Users, Member 187 Posts
    I tried with and without the space and got Invalid Email both ways. 
  • LudwigMonsterLudwigMonster Registered Users, Member 381 Posts
    Mulderken said:
    Same. Says my email address is invalid (which it's not). I've used the same email for the past two seasons.
    I also chose the "forgot my password" option in the 19 version and nothing got sent to me.
    Sent a ticket in to CS but I suppose I won't hear back from them for days. What a sh*t show.
    Check your spam box. 
    My gmail account doesn't have one.
  • SlashlineSlashline Registered Users, Member 34 Posts
    It hadn't required my email when I played 2019, so I never had one. I went back and in the settings, backed up my account (created an account) with an email. Then, back in 202, it recognized it OK.
  • LudwigMonsterLudwigMonster Registered Users, Member 381 Posts
    Over 8 hours and still no response from CS. Some VIP treatment there I tell ya.
    To add insult to injury, the marketing dept for Glu seem to recognize that I have a valid email 
    address, as I just had an invite in my inbox from them to play TSB 20.
    What the hell?
  • NoFreeRidesNugNoFreeRidesNug Registered Users, Member 4 Posts
    Yeah, I’m a VIP too and having the same exact problem. On 2019 it shows my email address is where my account is backed up to, and when I enter it in 2020, even if it’s to get my password reset, it says it’s invalid. Smh. Anyone got a solution?
  • NoFreeRidesNugNoFreeRidesNug Registered Users, Member 4 Posts
    Wrote them around noon and haven’t heard anything on either version 
  • fatDaddyfatDaddy Registered Users, Member 187 Posts
    edited March 17
    So much for Day 1 WoH. "VIP HOTLINE" going on 11 hours without a response. 
  • SandpipersSandpipers Registered Users, Member 1,327 Posts
    Took almost 2 full days and multiple CS agents to get the same thing sorted, with the same issues, with the beta release, on one of my accounts. The other account was instant. Good luck.
    It's all done with mirrors
  • qualifiedcaptainqualifiedcaptain Registered Users, Member 7 Posts
    I’m having the same issue except with my Facebook account. I’ve used the same email since 2018 and never had a problem. I’m VIP and sent an email and in game support but all they say is do this and do that but I’ve already done what they’ve said and it still doesn’t work. I’m missing out on valuable VIP resources. 
  • Tdub71Tdub71 Registered Users, Member 1,861 Posts
    I finally got in, and played fine all day.  No issues.  I sent a message on the VIP hotline, asking them to change the email that the account was backed up with (to my personal, rather than work). 

    After several hours with no response, I finally got a message that it was changed successfully.  The CS rep even confirmed the correct email, and gave me a new password.  Now I can't log in at all.  I tried the "forgot password" button, and got an invalid email message.

    So far no response in 3 hours.  If they get it fixed today, I will gladly continue to play.  If not, maybe this is a sign, and they are saving me from myself...
  • LudwigMonsterLudwigMonster Registered Users, Member 381 Posts
    Finally made it in on my own. What a PITA.
  • ThunderstormerThunderstormer Registered Users, Member 127 Posts
    How did you get in @LudwigMonster? Just doesn’t recognize my triple checked existing email. Wrote a ticket and tried to submit it, but instead of usual scripted first response got a bot that asked for my name “to start conversation” while totally disregarding my detailed ticket already sent... WTF, such a typical Glu-Up
  • Tdub71Tdub71 Registered Users, Member 1,861 Posts
    I got back into mine too.  I had to use the old email (which was the cause of the problem in the first place), and "forgot password" to reset it.  Still no acceptable solution to my issue, so far...
  • LudwigMonsterLudwigMonster Registered Users, Member 381 Posts
    edited March 17
    @Thunderstormer I first noticed that I hadn't backed up my '19 account, which is why it said
    my email was "invalid". But I am on the Glu mailing list and remember backing up my account before,
    so I then determined it was the '18 version that I backed up. I then backed up my '19 account and used
    the same log in credentials to sign in to '20. Still a PITA and they should really spend more time and effort in explaining to people what to do to access their multi-million dollar app.

  • eman0023eman0023 Registered Users, Member 156 Posts
    My iPad is having similar problems.  I logged in once.  Went back later that day and got logged out.  Each time I try again recovering my account, it says my email is already linked.  Can't play in the learning demo either as the game crashes at 91%.  Idk if I should try CS on my phone or try some other method. 
  • kck6894kck6894 Registered Users, Member 1 Posts
    I'm having the same issue. My 2019 is backed up. Shows my email. When I try to log in to 20. It won't accept my password and says my email is invalid. 

    I double checked it make sure my email was correct (no space after) but I still don't get anything 
  • NoFreeRidesNugNoFreeRidesNug Registered Users, Member 4 Posts
    It still doesn’t recognize my email that is attached to my 2019 account. Says the email address is invalid. Though it shows on my 2019 as my backup account. Pretty lame that so many people are having issues with it. Especially when most of them are VIPs so it seems
  • SakaV2SakaV2 Registered Users, Member 118 Posts


    Is this the message you all get ? 
  • NoFreeRidesNugNoFreeRidesNug Registered Users, Member 4 Posts
    And it’s my same exact email as my 2019 email that my account is backed up to 
  • EamusCatuliEamusCatuli Registered Users, Member 35 Posts
    Has anyone had this resolved through CS?  I sent them a message last night but no response. Wondering if I have to try something else. Thanks. 
  • Andy CAndy C New Member Registered Users, Member 4 Posts
    I am able to play 2020 but can't get my keepers from 2019 because of the email/password issue. Reported same on both 2019 and 2020 versions. Tried to reset my password but keep getting "invalid email/password combination ". 
    Sucks as I'm falling way behind in my club. 
Sign In or Register to comment.