I can’t play the trail of style leaderboard

nanaandhannanaandhan Registered Users, Member 1 Posts
1. When I enter the trail, it says “this trail is over, collect your reward”, but when I click the gift box beside the trail, there was no rewards 2. I can’t join the competition, it said “this is the previous Trial Leaderborad, join the next one”, but when I wait for the next trail, it’s still show the same even if reinstall the app, what’s going on?
Whether i can’t play this game forever? I really love this game and want to play the trail, what can I do?


  • Options
    KittyKatMeowKittyKatMeow Registered Users, Member 2 Posts
    I have the same issue, and submitting ticket just got me the response “Sorry, we are working on it. Here is 10 gold”.
  • Options
    twinklewindtwinklewind Registered Users, Member 8 Posts
    I had this before. You had to update the app.
  • Options
    AnnaML1AnnaML1 Registered Users, Member 3 Posts
    edited November 2021
    Just recently got this...Uninstalled, reinstalled, checked Google play for updates, signed out of and in to Facebook, etc. Contacted customer support and got 30 gold...great still no TOS.
    I can't find any additional update that I missed...very frustrating.

  • Options
    KittyKatMeowKittyKatMeow Registered Users, Member 2 Posts
    I am on a brand new phone with everything newly updated, and still unable to access Trial of Style. It has been months, and all I get copy paste messages and a bit of gold when I contact support.
  • Options
    debaskdebask Registered Users, Member 1 Posts
    I am unable to play Trial of Style.
  • Options
    AlkieAlkie Registered Users, Member 3 Posts
    Yeppers same here! I haven’t been able to play the Trial of Style at all either since getting back into this game and it’s a huge bummer.  Support said they are working on it, but gave no timeline for when they will have an actual fix.  It’s very frustrating to not be able to play in it and have at shot at some of the premium wheel spins etc.  
    Ive also tried uninstalling and reinstalling which was brutal because the Facebook link/ save point didn’t work so support had to fix that for me.  
Sign In or Register to comment.