Game reset and my game said that my phone was rooted.

:mad: I worked so hard to get to level 71 and finished most upgrades to my equipments that I owned...Maxed out Bane and all the defense items leaving only one last upgrade left for each. I have played two tournaments time to time, because it takes forever to enter just one round. Anyway, this tournament thing is brilliant, and I was so excited to play the new tournament that started yesterday. After playing two successful rounds, my phone slowed down, so I exit the game to clean up some RAM to see if I could get an extra boost...when I returned to the game...my character standing there with the piece of crap weapon without the armors. My character was set to level 1.
I restarted the game couple of times, but no change of the status. I finished initial stage to get to main menu to load from the google plus account. Level was dropped to 67 and then most of the weapon updates gone...:(
I tried to calm down and accept. Time will heal...right?
Then I encountered with a bigger issue, my game won't let me join the Pvp, because it said that my phone was rooted, which is not. I wonder if they could fix this rooted phone status I would get back the level 71 or I should be happy to keep at least level 67. Better yet is it even possible to fix the rooted problem.
What are your predictions???
Thx for reading looooooooooooong thread.

Comments

  • zabar4ozabar4o Registered Users 3 Posts
    The same thing happened to me - i played 1 tournament and really enjoyed it , but after the last update i lost everything and the cloud save was at least 1 month old.When i started the game next time all was reset AGAIN and when i load from cloud i am still lvl 1.And yes - now i cant play tournament because of the ROOTED problem.There was not any fixes since then.Yesterday i got the same problem with Heroes of Destiny so i think it gets worse with Glu games.Sorry ,but i just don't want to start all the games from the start.
  • JKRevanJKRevan Registered Users 4 Posts
    Same thing happened to me, but my level was reverted Irrestorably to 1, I leveled it up again up to 35, regaining my gear, but i just got resetted AGAIN today

    and STILL CANT JOIN PVP
  • renerene Registered Users 2 Posts
    Me to wtf lemme kno if you get resolved
  • hammilljrhammilljr Registered Users 1 Posts
    What have they done to fix these issues? I was level 50 and got reset to 20 and lost all my gear, money, and time.
    rene wrote: »
    Me to wtf lemme kno if you get resolved
Sign In or Register to comment.