Reporting Bugs and Issues

SuperFlanSuperFlan Registered Users, Administrator, Member 52 Posts
edited July 2019 in Bugs and Issues
Hey Y'all! Hope everyone is having fun saving the town in Diner DASH Adventures!

And thanks for helping us weed out the bugs! If you're reporting a bug or issue, please provide as much detail as possible.
Details such as:
  1. Venue/Chapter/Level - let us know exactly where this is happening
  2. What triggered the issue - Did you tap on a character? Collect a reward? This can help us reproduce the issue!
  3. Device info - iPhone XR? Galaxy S9? Again, this helps!
  4. Screenshots - This is important if the issue is visual. Multiple screenshots are okay, especially when placed in order.
Thanks for the help everyone!


  • Tink1207Tink1207 Registered Users, Member 1 Posts
    Ipad mini will download, show opening scenes then freeze at 30% with Device not compatible? 

  • morienkamorienka Registered Users, Member 1 Posts
    Hi, I’m currently in trout level, awaiting the cruise ship to become available, however, I have been unable to play these last couple of days as it won’t load the game. Is there an upgrade in progress or is there a fault with it,?
  • tocadetocade Registered Users, Member 1 Posts
    1. Venue/Chapter/Level - hotel chapter 7 level 12
    2. What triggered the issue - My game updated last night.  After the update I couldn't play it kept telling me the level was downloading. This morning I was able to start the level but it kept freezing and not allowing me to play the level however the time was still ticking and I lost supplies for that level.
    3. Device info - Samsung Galaxy s7

  • donnabdonnab Registered Users, Member 1 Posts
    Hi I’m on chapter 4 level 8 in the mini golf and the stars are not loading. It acts like I haven’t gotten any even though I have 
  • PriderPrider Registered Users, Member 2 Posts
    So I posted this last week and never heard anything and this just happened again ... I lost 4 gems without buying an upgrade. I got one from watching an ad, it was counted and appeared in my gems, then I bought three from the daily purchases using in game coins.  I didn't have any coins left to purchase upgrades so started playing various levels in the Inn (levels 6-8). I played two rounds and noticed the 4 gems I had acquired not more then 10 minutes ago had disappeared.  I have now had 13 gems disappear. 

  • AniqueAnique Registered Users, Member 1 Posts
    Hello!  I have enjoyed playing this game.  Here is my current problem.  I use an iPad.  During the Game of thorns event, when I go into play the levels, I get this
    Ithis only occurs during the game of thorns, I can play every other level except the event.  Retrying does not work and neither does restart.  
    Thanks for your help in advance.

  • carianncariann Registered Users, Member 1 Posts
    I am having the same issue with the game of thrones event.
  • DecembersolDecembersol Registered Users 2 Posts
    I am having the same issue.  Game of Thorns level 6.  Works on all other chapters.
  • kholt22kholt22 Registered Users, Member 2 Posts
    I am having the same issue as well. Game of Thorns, chapter 7, unable to play and I’ve tried several different places around my home, turned my phone off and on, and tried to reboot the WiFi as well but nothing worked. 

  • JAMEYOJAMEYO Registered Users, Member 1 Posts
    I am having the same issue I can't launch the Event with my Galaxy S10, although it worked last night without issue. I tried clearing cache and uninstalling and reinstalling with no change. The rest of the game works fine. 

  • klovieklovie Registered Users, Member 1 Posts
    I am on the cruise chapter 15 level 12 and the game wont allow me to enter my to do list. When I try it wont open but it repeats the convo between the goons and then it just freezes there. The only way I can continue to play is to exit the game and restart but it still won't allow me to enter the to do list. My device is a samsung galaxy A5.
  • SuperFlanSuperFlan Registered Users, Administrator, Member 52 Posts
    Hey everyone! 

    Apologies for the late replies. I"ll answer the questions I can here, but some of these may require Customer Care tickets since I don't have the same access they do in forums. Also, I'll be closing this thread and will ask y'all to create or find discussions with your bugs. Keeping them here will make it very messy and I'd rather give everyone the focus they deserve :smile:

    For device compatibility, please check this FAQ:

    If a venue or asset appears as "downloading," please allow a few minutes to finish the process. Sometimes the game will attempt to redownload EVERYTHING, which can take a bit of time. 

    If you believe you're missing gems/coins/stars, this will be a Customer Care situation. They can check logs and see what kind of activity has been recorded (screenshots are your best friends here!)

    Game of Thorns issue! We took care of this one on the day it occurred, so thanks for posting these with screenshots and writing in everyone. 

    For the most recent post, this sounds new. Please send in a ticket (which I will keep an eye out for) so we can send it to the dev team. Please include the name of the Quest you're attempting to do.

    Thanks again everyone! And just one more time, I'll be closing this thread so reported issues aren't mixed in with one another. 

This discussion has been closed.

Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.