my device is not compatible with this application

kramleinadseyerkramleinadseyer New MemberRegistered Users 1 Posts
I was able to install this game few months ago but as time passby, my phone is not compatible with this game anymore.. My phone is sony LT26ii (xperia SL).. Please do something about it, my lvl is already 65.. Thank you and God Bless!
Sign In or Register to comment.