the swift life doesn't work on my iPad mini

I have the swift life for my iPad mini running iOS 9.3.5, the app is downloaded to the my Ipad but after launching it I get the same message sorry your device isnt supported, why? if my devices isnt supported why was I able to download the app in the first place, please update the app so I can use it on my iPad.
Sign In or Register to comment.