Over the course of the last five years, Racing Rivals has grown into one of the most hardcore racing games in the world. This loyal community has spent countless hours competing in millions of races in “winner take all” fashion – all in the name of Turf Wars and pink slips.

However, all good things must come to an end… After spending time evaluating Rivals and its future – we’ve decided that it’s time to move on. Simply put, the revenue generated from Racing Rivals unfortunately no longer covers the cost of operations. This was not an easy decision to make.

On March 31st, 2019 – Rivals will be racing off into the sunset, and will be permanently shut down. Current players have until this date to utilize any accumulated virtual currency. We’ll be offering some massive reductions in the cost of crates, installs and repairs in addition to a reduction on timers as you race your way into the history books. Effective immediately, no new in-app purchases will be permitted.

In closing, a resounding and sincere THANK YOU to our extremely driven fans for your loyalty and dedication over the years – we hope you’ve enjoyed playing Racing Rivals as much as we’ve enjoyed creating it.

6.1 Bug Reports

2

Comments

  • aubassplayeraubassplayer Junior Member Registered Users 2,725 Posts
    Moto G 4th gen still super laggy on launch and shifts @ryyst
    Ign: au(space)bass(space) player
    Team: 9am michi
  • 2INURPINk2INURPINk Registered Users 18 Posts
    edited December 2016
    Veteran player here so far the updates are amazing but some temporary issues.thanks guys good work.. .Since todays 6.1 update lost 3 cars.soon realized my Launch bottom is not working 50% of time. Also when player/friend gets online the notification box blocks view of lights when launching at beginning of race.. Galaxy note 4 edge/ ign INYOWIFEY LOL
  • Spaghetti 42Spaghetti 42 Senior Member Registered Users 958 Posts
    IGN: Spaghetti 42
    iPhone 6
    IOS 10.2
    Dead Launch
  • cuzz21cuzz21 Junior Member Registered Users 45 Posts
    Launch not working.....50% of the time

    Tried all settings options to fix issue with no success

    iPhone 7

    Ign: MIKEYBEE
  • greenburnout303greenburnout303 Junior Member Registered Users 1,975 Posts
    Wheels- black pacer 162m we first place black version.
    Both normal and experimental gfx
    Wheels are solid color instead of having normal chrome lip/gloss black faces
  • henry06xhenry06x Registered Users 5 Posts
    Are they GRAM 57s-pro white ($40,000) wheels ever going to get fixed to look white?

    They still look exactly like the basic 57s-pro's and the white ones are one of my favorite sets of wheels in the game. I have them on quite a few cars and if sucks that it cost $35,000+ more for them to now look exactly like the cheaper ones.
  • APOAPO Registered Users 6 Posts
    edited December 2016
    Launch not working properly.


    Samsung galaxy

    Mwp apo lupin
  • cagedbullcagedbull Senior Member Registered Users 184 Posts

    Please report any issues with 6.1 here. Be sure to include your racer name and any and all pertinent information.

    Known Issues:

    Personal Mechanic Error - Uninstalling an axle from the Personal Mechanic screen will cause an error. Uninstalling from the upgrade screen will work

    511 Error - If you try upgrading through the Personal Mechanic (Alex) too quickly, you may get a 511 error causing a restart

    Stuck In the Garage - If your active car is currently awaiting delivery, you can become stuck in the Personal Mechanic tutorial when starting the game for the first time since updating. Currently there is no easy workaround except waiting for your delivery to complete.

    Investigating

    Unable to Launch - Seeing reports of players tapping launch but nothing happens.

    Are you going to replace cars lost to launch button not working or is that another " unsupported " portion of the game. lmao.
  • rrcjrrcj Registered Users 2 Posts
    Launch button not working. Samsung Galaxy s7 edge
  • ihateoystersihateoysters Registered Users 24 Posts
    Samsung Galaxy Tab A.
    Launch button problem....
    Terrible lag when shifting and launching.
  • SpeedTrappSpeedTrapp Registered Users 123 Posts
    It has been more than a month since 6.0 got released and we still have the same issues bad lag, choppy FPs, and bad wheels colors. Now the launch button is not working properly and GLU is so stubborn to keep adding features while they should be fixing the bloody game.

    Game was better with 5.3 and as updates get released the interest for this game dies more and more.
  • [RR] Ryyst[RR] Ryyst Administrator Registered Users, Moderators 3,814 Posts
    Hey everyone, We're still trying having issues trying to reproduce the launch button issue.

    Does this happen with any car you use?

    For those who play on multiple devices, does it happen on each device?

    Does it happen in any race mode?

    Multiplayer?
    Tournament?
    Quick Match?
    Driver's Challenge?
    Test Track/Drive?
    IGN: The Real {RR} Ryyst
    Soon to be Ex-Carbonated Community Manager

  • Roush SportRoush Sport Registered Users, Moderators 1,487 Posts
    edited December 2016
    Ryyst, yes - happens with any / every car, in every race mode. With mine, the launch button functionality is intermittent. Sometimes it works as it should, other times I have to tap it several times to get it to trigger. I've been attempting to run most of the morning, and the launch button malfunction happens 1 out of every 3 races.

    I can't answer about the multiple devices, as I only run the game on my IPhone currently.
  • APOAPO Registered Users 6 Posts
    edited December 2016
    I use two device in my account but same problem. Launch and lag in any race mode. My device is samsung galaxy and HTC.
  • Antony_HopkinsAntony_Hopkins Registered Users 4 Posts

    often fails nitrous button, because it is constantly losing the car, please correct
  • dwdtuningdwdtuning Registered Users 12,932 Posts
    Are they replacing cars cause of failed launch button. Or is it somehow are fault for pinking? Should no one pinks anymore for the shear fact that your product is faulty?
    ★ HATERS MAKE US FAMOUS ★

    ★#1 MM ★

    ☆ Stalkers are creepy ☆

    >:)
  • [RR] Ryyst[RR] Ryyst Administrator Registered Users, Moderators 3,814 Posts

    Ryyst, yes - happens with any / every car, in every race mode. With mine, the launch button functionality is intermittent. Sometimes it works as it should, other times I have to tap it several times to get it to trigger. I've been attempting to run most of the morning, and the launch button malfunction happens 1 out of every 3 races.

    I can't answer about the multiple devices, as I only run the game on my IPhone currently.

    Can you intentionally foul? Basically do you experience the same thing if you foul, do you also have to press the launch button a few times before you register the foul?
    IGN: The Real {RR} Ryyst
    Soon to be Ex-Carbonated Community Manager

  • dwdtuningdwdtuning Registered Users 12,932 Posts
    10 other people posted experiencing same issue and yet you don't ask anyone else anything. Pathetic
    ★ HATERS MAKE US FAMOUS ★

    ★#1 MM ★

    ☆ Stalkers are creepy ☆

    >:)
  • Roush SportRoush Sport Registered Users, Moderators 1,487 Posts
    edited December 2016

    Ryyst, yes - happens with any / every car, in every race mode. With mine, the launch button functionality is intermittent. Sometimes it works as it should, other times I have to tap it several times to get it to trigger. I've been attempting to run most of the morning, and the launch button malfunction happens 1 out of every 3 races.

    I can't answer about the multiple devices, as I only run the game on my IPhone currently.

    Can you intentionally foul? Basically do you experience the same thing if you foul, do you also have to press the launch button a few times before you register the foul?
    Just ran several test races in a 1621 rated 2015 Ford Mustang GT - against both bots, and other racers. Intentionally fouling works without issue. The moment I touch the launch button, it fouls.
  • C y r u sC y r u s Junior Member Registered Users 293 Posts
    Ran on 3 devices including bluestacks on my computer and it happens on all of them. I find it hard to believe your having a hard time reproducing the launch problem as I, as well as most others, have no problem at all recreating it. It happens once every 3 to 4 races. Grab an iOS or android device and join any lobby in any race mode, you'll have no problem recreating it.
  • dwdtuningdwdtuning Registered Users 12,932 Posts
    edited December 2016
    @c r y u s lol I just jumped on. First race. Reproduced.
    ★ HATERS MAKE US FAMOUS ★

    ★#1 MM ★

    ☆ Stalkers are creepy ☆

    >:)
  • C y r u sC y r u s Junior Member Registered Users 293 Posts
    Lol
  • Roush SportRoush Sport Registered Users, Moderators 1,487 Posts
    @C y r u s, @dwdtuning - Can you try, when launching, tapping the top of the launch button, or even just slightly above the launch button, and post the results?
  • dwdtuningdwdtuning Registered Users 12,932 Posts
    @Roush Sport i pmed you answer to that last night. When it does fire, I have to hit bottom left of launch button. Whole button nothing, top left nothing, top right nothing, bottom right nothing. I can foul tho if I want. Still only works bottom left of launch button for that also.
    ★ HATERS MAKE US FAMOUS ★

    ★#1 MM ★

    ☆ Stalkers are creepy ☆

    >:)
  • dwdtuningdwdtuning Registered Users 12,932 Posts
    That's on my Moto g and my galaxy note 3. Both Android
    ★ HATERS MAKE US FAMOUS ★

    ★#1 MM ★

    ☆ Stalkers are creepy ☆

    >:)
  • Roush SportRoush Sport Registered Users, Moderators 1,487 Posts
    @dwdtuning Thank you - just wanted to make sure it's still the same today. My issue is just the opposite. If I tap the middle or bottom of the button, nothing. If I tap the top, or slightly above the button, it triggers as it should. Just trying to help the team gather as much info as possible on the issue.
  • dwdtuningdwdtuning Registered Users 12,932 Posts
    @Roush Sport np brotha
    ★ HATERS MAKE US FAMOUS ★

    ★#1 MM ★

    ☆ Stalkers are creepy ☆

    >:)
  • CHSJACHSJA Junior Member Registered Users 407 Posts
    Asus Memo pad 7 LTE
    Android 4.4.4
    Latest game update.
    Intermittent dead launch. Showdown, multiplayer, tournament. Pinks or free races.
    Multiple color issues, matte black looks like regular paint if your racing, in the garage it looks correct.
    Multiple wheel issues still, most notably COPOS.


    Alcatel One touch
    Andriod 4.4.2
    Latest game update.
    Intermittent dead launch. Showdown, multiplayer, tournament. Pinks or free races.


    Samsung - Galaxy Tab A
    Android 5.0 Lollipop
    Latest game update.
    Intermittent dead launch. Showdown, multiplayer, tournament. Pinks or free races.
    Matte paint issues here also. Look "ok" in garage, but one you take it to a race, looks not matte.



    Bluestacks
    Cant get it to fcking load..
  • [RR] Ryyst[RR] Ryyst Administrator Registered Users, Moderators 3,814 Posts
    For those experiencing this, did you go through the
    dwdtuning said:

    10 other people posted experiencing same issue and yet you don't ask anyone else anything. Pathetic

    Anything I post here is open to all. Just didn't need to flood the page with replies asking the same question.Plus Roush is a MOD and tends to be a bit more rational when answering and less... I don't know, abusive?
    IGN: The Real {RR} Ryyst
    Soon to be Ex-Carbonated Community Manager

  • [RR] Ryyst[RR] Ryyst Administrator Registered Users, Moderators 3,814 Posts
    C y r u s said:

    Ran on 3 devices including bluestacks on my computer and it happens on all of them. I find it hard to believe your having a hard time reproducing the launch problem as I, as well as most others, have no problem at all recreating it. It happens once every 3 to 4 races. Grab an iOS or android device and join any lobby in any race mode, you'll have no problem recreating it.

    And yet its the truth. Myself and the QA staff on multiple devices played the game, never had any of us run into this issue. I have also talked to many other players who also have never run into this issue. While vocally it would appear to be rampant, we also haven't had many tickets coming in regarding this issue.

    So, I'm here trying to gather more information on why this is happening to some players and not at all to others.
    IGN: The Real {RR} Ryyst
    Soon to be Ex-Carbonated Community Manager

Sign In or Register to comment.